好股票網每日提供最新股票軟件下載,如果您覺得不錯,麻煩推薦給您的好友,謝謝!
您現在的位置:好股票網 >> 股票公式 >> 通達信公式

MACD神器副圖指標 通達信 貼圖

[下載地址]

好股票網經過測試可運行,該軟件通過多款專業殺毒軟件掃描

  • 360通過
  • 金山通過
  • 瑞星通過
  • 江民通過
  • 卡巴通過
  • 諾頓通過
  • 運行平臺:Win7/Vista/WinXP/Win2003/
  • 公式語言:簡體中文
  • 更新時間:2019-10-11 08:53:00
  • 公式評級:
  • 公式類型:通達信公式
  • 授權方式:共享版
  • 公式大小:7.00 KB
  • 解壓密碼:goodgupiao
  • 下載統計:
  • 相關Tags:
已有次下載
推 薦0
不推薦0

MACD神器副圖指標 通達信 貼圖介紹

好股票軟件下載網(www.uaksfl.live)提示:您正在下載的是:MACD神器副圖指標 通達信 貼圖

MACD低結構、空中加油、買賣點提示


{①頂背離,底背離提示(形成會有文字提醒,鈍化不代表一定會形成)
②高九,低九(遇9就轉,有朋友說有未來也是在這里,出7或8有的情況下不一定會出9,創新低或創新高7或8會消失,但9只要出現就不會更改,也不會漂移,只看9操作就可以)
③MACD買點(紅色三角形)
④MACD低買(軸下金叉)
⑤MACD加油(軸上金叉)
⑥MACD翻紅(二次買點)}
DRAWGBK(O>C,RGB(40,40,40),RGB(0,0,40),0,'01',0); {背景不要可刪除}
DIF:100*(EMA(CLOSE,12)-EMA(CLOSE,26)),COLORWHITE,LINETHICK1;
DEA:EMA(DIF,9),COLORYELLOW,LINETHICK1;
MACD:(DIF-DEA)*2,COLORSTICK;
{
STICKLINE((MACD>=0),0,MACD,2,-1),COLOR0000FF;
STICKLINE(((MACD>=0) AND (MACD < REF(MACD,1))),0,MACD,2,0),COLOR0090FF;
STICKLINE((MACD<0),0,MACD,2,0),COLORGREEN;
STICKLINE(((MACD<0) AND (MACD > REF(MACD,1))),0,MACD,2,-1),COLORCYAN;
STICKLINE(CROSS(DIF,0),0,MACD,2,0)COLORMAGENTA;
STICKLINE(CROSS(0,DIF),0,MACD,2,0)COLORWHITE;
}
STICKLINE((MACD>=0),0,MACD,1,0),COLOR0000FF;
STICKLINE(((MACD>=0) AND (MACD < REF(MACD,1))),0,MACD,1,-1),COLOR0090FF;
STICKLINE((MACD<0),0,MACD,1,1),COLORGREEN;
STICKLINE(((MACD<0) AND (MACD > REF(MACD,1))),0,MACD,1,0),COLORCYAN;
STICKLINE(CROSS(DIF,0),0,MACD,1,0),COLORMAGENTA;
STICKLINE(CROSS(0,DIF),0,MACD,1,0),COLORWHITE;

FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
FH5:=FH1 AND FH2 AND MACD<0.10;
二次翻紅:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
低買:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
DRAWICON(二次翻紅,-0.05,1);
DRAWTEXT(二次翻紅,-0.15,'↖翻紅'),COLORRED;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低買'),COLORFF00FF;
DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;
XG:二次翻紅 OR 低買 OR 加油,NODRAW;
YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
A1:=C>REF(C,4);
NT:=BARSLASTCOUNT(A1);
TJ11:=NT=9;
TJ13:=ISLASTBAR AND BETWEEN(NT,5,8);
AY:=(BACKSET(TJ11>0,9) OR BACKSET(TJ13>0,NT))*NT;
DRAWTEXT(AY>0,MACD*1.02,VAR2STR(AY,0)),COLORLIRED;
DRAWTEXT(NT=9,MACD*1.02,'9'),COLORGREEN;
B1:=C<REF(C,4);
NT0:=BARSLASTCOUNT(B1);
TJ21:=NT0=9 ;
TJ23:=ISLASTBAR AND BETWEEN(NT0,5,8);
AY1:=(BACKSET(TJ21>0,9) OR BACKSET(TJ23>0,NT0))*NT0;
DRAWTEXT(AY1>0,MACD*0.98,VAR2STR(AY1,0)),COLORGREEN;
DRAWTEXT(NT0=9,MACD*0.98,'9'),COLORRED;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉),NODRAW;{最近一次死叉的位置}
N2:=REF(BARSLAST(死叉),N1+1),NODRAW;{倒數第二次死叉與倒數第一次死叉的區間}
N3:=REF(BARSLAST(死叉),N2+N1+2),NODRAW;{倒數第三次死叉與倒數第二次死叉的區間}
CL1:=LLV(C,N1+1),NODRAW;{最近一次死叉后,最低收盤價}
DIFL1:=LLV(DIF,N1+1),NODRAW;
CL2:=REF(CL1,N1+1),NODRAW;{倒數第二次死叉與倒數第一次死叉之間的最低收盤價}
DIFL2:=REF(DIFL1,N1+1),NODRAW;
CL3:=REF(CL2,N1+1),NODRAW;{倒數第三次死叉與倒數第二次死叉之間的最低收盤價}
DIFL3:=REF(DIFL2,N1+1),NODRAW;
PDIFL2:=IF(DIFL2>0,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL3>0,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背離:=(CL1<CL2 ) AND (MDIFB2>MDIFL2) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB2<=REF(MDIFB2,1);
隔峰底背離:=(CL1<CL3 AND CL3<CL2 ) AND (MDIFB3>MDIFL3) AND (MACD<0 AND REF(MACD,1)<0) AND MDIFB3<=REF(MDIFB3,1);
底部鈍化:直接底背離 OR 隔峰底背離,NODRAW;
底背離:((MDIFB2>REF(MDIFB2,1))*REF(直接底背離,1)) OR ((MDIFB3>REF(MDIFB3,1))*REF(隔峰底背離,1)),NODRAW;{好股票www.uaksfl.live}
底背離消失:=(REF(直接底背離,1) AND DIFL1<=DIFL2 ) OR (REF(隔峰底背離,1) AND DIFL1<=DIFL3);
{DRAWTEXT(TFILTER(底部鈍化,(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1)),1),DIFL2,'鈍化'),COLORYELLOW;}
STICKLINE(底部鈍化,DIF,DEA,1,0),COLORMAGENTA;
DRAWTEXT(TFILTER(底背離,C<REF(CL1,1),1),DIF*1.12,'結構形成'),COLORMAGENTA;
{DRAWTEXT(FILTER(底背離消失,10),(DIF+MACD),'消失'),COLORGREEN;
STICKLINE(底背離,0,(DIF+DEA),5,0), COLORRED;}


金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉),NODRAW;{最近一次金叉的位置}
M2:=REF(BARSLAST(金叉),M1+1),NODRAW;{倒數第二次金叉與倒數第一次金叉的區間}
M3:=REF(BARSLAST(金叉),M2+M1+2),NODRAW;{倒數第三次金叉與倒數第二次金叉的區間}
CH1:=HHV(C,M1+1),NODRAW;{最近一次金叉后,最高收盤價}
DIFH1:=HHV(DIF,M1+1),NODRAW;
CH2:=REF(CH1,M1+1),NODRAW;{倒數第二次金叉與倒數第一次金叉之間的最高收盤價}
DIFH2:=REF(DIFH1,M1+1),NODRAW;
CH3:=REF(CH2,M1+1),NODRAW;{倒數第三次金叉與倒數第二次金叉之間的最高收盤價}
DIFH3:=REF(DIFH2,M1+1),NODRAW;
PDIFH2:=IF(DIFH2>0,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH3>0,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接頂背離:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰頂背離:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
頂部鈍化:直接頂背離 OR 隔峰頂背離,NODRAW;
頂背離:((MDIFT2<REF(MDIFT2,1))*REF(直接頂背離,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰頂背離,1)),NODRAW;
{DRAWTEXT(TFILTER(T,(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1)),1),DIFH2,'鈍化開始'),COLORYELLOW;}
STICKLINE(頂部鈍化,DIF,DEA,1,0),COLORGREEN;
DRAWTEXT(TFILTER(頂背離,C>REF(CH1,1),1),DIF*1.12,'結構形成'),COLORGREEN;
DRAWICON(CROSS(DIF,DEA),DEA,36);
DRAWICON(CROSS(DEA,DIF),DEA,37);
MACDDIF:=IF(ABS(MACD)>ABS(DIF),MACD,DIF);
DRAWICON(REF(DIF,1)>REF(DIF,2) AND DIF<REF(DIF,1) AND DIF>0 AND DIF>DEA,MACDDIF*1.1,39),COLORGREEN;
DRAWICON(REF(DIF,1)<REF(DIF,2) AND DIF>REF(DIF,1) AND DIF<0 AND DIF<DEA,MACDDIF*1.1,38),COLORRED;

{主力異動}
VARRR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARRR2:=EMA(VARRR1,30);
VARRR3:=EMA(VARRR2,30);
VARRR4:=3*VARRR2-2*VARRR3;
勢:=EMA(VARRR4,5),COLORBLUE,LINETHICK3;
VARRR5:=LLV(LOW,10);
VARRR6:=HHV(HIGH,25);
決策線:=EMA((CLOSE-VARRR5)/(VARRR6-VARRR5)*100,4),COLORRED,LINETHICK2;
{DRAWTEXT(CROSS(80,決策線),75,'小心')COLORWHITE;}
五十:=50,POINTDOT,COLORYELLOW;
十:=10,COLORYELLOW;
八十:=80;
{STICKLINE(勢>80,勢,80,1,0),COLORGREEN;}
STICKLINE(勢<10,勢,10,1,0),COLORWHITE,LINETHICK2;
DRAWTEXT(CROSS(10,勢),52,'進→'),COLORYELLOW;
DRAWTEXT(CROSS(10,勢),42,'入'),COLORFF00FF;
DRAWTEXT(CROSS(10,勢),32,'異'),COLOR00C0FF;
DRAWTEXT(CROSS(10,勢),22,'動[↓]'),COLORB47DFF;
DRAWTEXT(CROSS(10,勢),12,'區'),COLORFFFF6F;



MACD神器副圖指標 通達信 貼圖


好股票軟件下載網(www.uaksfl.live)提醒您:股市有風險,投資需謹慎。
相關說明
  • 好股票軟件下載網歡迎用戶將網頁內容和下載地址轉發到博客、微博、論壇等。
  • 發布的公式指標絕大部分是來源于各大論壇,謝謝各位老師的原創指標。
  • 判斷公式指標好壞,請用戶參考用戶評論或者軟件好評度
  • alg格式股票公式,僅僅可以用飛狐交易師股票軟件引入使用;
  • fnc格式股票公式,可以用大智慧新一代高速行情分析系統股票軟件使用,少部分可以用分析家股票軟件引入使用;
  • exp格式股票公式,僅可以用大智慧經典版股票軟件引入使用;
  • tnctni格式股票公式,僅可以用通達信新引入使用,例如可以用通達信股票軟件引入使用;
  • tne格式公式,僅可以用通達信公式編輯器5.0版導入,高版本兼容低版本;
  • hxf格式股票公式,僅可以用同花順股票軟件引入使用。
  • 如果引入公式的時候,發現公式名稱欄空白,調整電腦時間到1997年,能出現公式名稱并正常顯示,可能是公式使用期限已過。
  • 如果您發現下載鏈接錯誤,請點擊報告錯誤謝謝!
pc蛋蛋不翻倍挂机模式